Welcome to the Nexpose Community

Document created by techeditor on Apr 8, 2011Last modified by patrick_hellen on Oct 18, 2012
Version 32Show Document
  • View in full screen mode

Nexpose is an award-winning vulnerability management solution from Rapid7. The Nexpose Community Edition is a free version of Nexpose that scans routers and operating systems for vulnerabilities. In addition, the Community Edition integrates with the Metasploit Exploit Framework. Commercial editions include additional features such as distributed scanning, more flexible reporting, and web/database scanning. Commercial editions also include product support. For more information about the various Nexpose editions, visit Rapid7. For more information about Rapid7 and what's happening, visit or subscribe to our blog.

 

This website focuses on the Nexpose Community edition but has resources that should be useful to all Nexpose users.

 

General FAQ
Technical FAQ
Reporting FAQ
Product Registration and Licensing FAQ

 

Community

................................................................................ ................................................................................ .......................................................................

How can you contribute or participate?

  • Participate in the community! Join here and start adding your own content.
  • You can interact with other members of the community on the official Rapid7 IRC channel.
    • Server: irc.freenode.net
    • Channel: #rapid7

 

Nexpose Quick Start

................................................................................ ................................................................................ ...................................................................

  1. Review the system requirements for Nexpose Community Edition
  2. Download the Nexpose Community Edition
  3. Install Nexpose (Follow the Install Guide)
  4. Browse to https://<yourip>:3780 and login using the username and password you specified during installation

 

       For more information on scanning check Getting Started Scanning with Nexpose

 

Metasploit + Nexpose Quick Start

................................................................................ ................................................................................ ...................................................................

  1. Install Nexpose following the above steps.
  2. Download and install the latest version of Metasploit. You will need Metasploit 3.3.1 in order to integrate with NeXpose.
  3. Start NeXpose and then launch the Metasploit Console (msfconsole)
  4. Follow the Metasploit Framework NeXpose Plugin guide

Resources

................................................................................ ................................................................................ ...................................................................

General FAQ
Technical FAQ
Reporting FAQ
Product Registration and Licensing FAQ
Video Tutorials

 

User Guide


 

Customization and Integration


 

Troubleshooting + Maintenance


Note: Not all of the functionality discussed in the following guides is available in the free community edition of NeXpose. Please see NeXpose Editions for more information.


 

Known Issues
Common Errors
Community Release Notes

Attachments

    Outcomes