Metasploit Pro 4.2.0 Update 2012031403

Document created by jcran on Mar 14, 2012Last modified by jcran on Mar 15, 2012
Version 4Show Document
  • View in full screen mode

Summary

This week's update brings one new module and fixes several pro-customer and community-reported bugs. Specifically, we now import vulnerability names from qualys reports and no longer throw an exception when generating the "Compromised Hosts" report.

See Tod's blog post for additional details.

Module Changes

 

Resolved Bugs & Changes

  • Issue #6501 : Variable scope now managed correctly when launching a module.
  • Issue #6465 : Importing Qualys Scan XML now imports vulnerability names.
  • Issue #6235 : Cleaned up report generation on the "Compromised Hosts" report.
  • Issue #6473 : Cleaned up a typo on the exception handled page.

 

How to Upgrade

Metasploit Pro is upgraded using the Administration menu and choosing the option Software Upgrade. To see how to upgrade your Metasploit installation, view this video in the Rapid7 Community.

Version Information

PRO 4.1.4 2012030701 revision 77a22839baf485de434bf79a4e04c9b38168d61f updates to 2012031403 revision d81f2b5b5a7f6ff34e40aab80b85ed094b7b0449

MSF3 4.1.4 2012030701 revision 6b9a21936e7c8be43dd002b242cc30841abde3a5 updates to 2012031403 revision b5fea8cd354f816b383a25f7a5e0a568ed45cd3b

Attachments

    Outcomes