AnsweredAssumed Answered

is_known_pipename (CVE-2017-7494) not working

Question asked by E J on May 31, 2017
Latest reply on Jun 2, 2017 by E J

Hi,

In order to do some internal tests for this vul I pulled (git clone) the SambyCry metasploit module from https://github.com/Waffles-2/SambaCry

After putting it into my ~/.msf4/modules/exploits/linux/samba, I fired up msfconsole (Kali installation) and did a "exploit/linux/samba/is_known_pipename".

It immediately bailed out with

[-] The supplied module name is ambiguous: uninitialized constant Msf::Modules::Mod6578706c6f69742f6c696e75782f73616d62612f69735f6b6e6f776e5f7069 70656e616d65::MetasploitModule::ARCH_MIPS64LE.

 

Anybody out there seen this? Any known cure against this problem?

 

Thanks much in advance for any clue,

-ej

Outcomes