mrpaul

Nexpose API, Ruby update, & Nokogiri

Discussion created by mrpaul on Jan 20, 2015
Latest reply on Jan 29, 2015 by gavin

In case others have this same problem.

 

My Nexpose API ruby scripts stopped working.  Authentication failed b/c the script was using a version of SSL or TLS that is vulnerable, and my Nexpose server didn't allow it.  (We keep that server patched too!) So... I installed the latest version of Ruby that is pre-built for windows, 2.1.5. (looks like none of the differences between 2.2.0 and 2.1.5 are related to SSL or TLS, so it should be good).  After that, I had to reinstall my gems.  Nexpose now requires the Nokogiri gem, which has never caused a problem for me in the past.  But, this time, I am encountering all sorts of problems installing the Nokogiri gem, including conflicting information (the gem website says not to use DevKit, but the gem installer told me I needed to have DevKit).

 

The solution appears to be simple.  Before installing the nokogiri gem, run gem update

 

Hope this saves others the hours it cost me...

 

Paul

Outcomes