AnsweredAssumed Answered

Cannot allocate memory - infocmp (Errno::ENOMEM

Question asked by Rakshith G on Mar 14, 2017
Latest reply on Mar 20, 2017 by Null Security

Hey guys, im no pro in metasploit and I'm new to Kali Linux and I after I had generated a payload for Android . I ran msfconsole but found this error

 

root@kali:~# msfconsole

                                                 

 

 

______________________________________________________________________________

|                                                                              |

|                   METASPLOIT CYBER MISSILE COMMAND V4                        |

|______________________________________________________________________________|

      \                                  /                      /

       \     .                          /                      /            x

        \                              /                      /

         \                            /          +           /

          \            +             /                      /

           *                        /                      /

                                   /      .               /

    X                             /                      /            X

                                 /                     ###

                                /                     # % #

                               /                       ###

                      .       /

     .                       /      .            *           .

                            /

                           *

                  +                       *

 

 

                                       ^

####      __     __     __          #######         __     __     __        ####

####    /    \ /    \ /    \      ###########     /    \ /    \ /    \      ####

################################################################################

################################################################################

# WAVE 4 ######## SCORE 31337 ################################## HIGH FFFFFFFF #

################################################################################

                                                           http://metasploit.pro

 

 

 

 

Frustrated with proxy pivoting? Upgrade to layer-2 VPN pivoting with

Metasploit Pro -- learn more on http://rapid7.com/metasploit

 

 

       =[ metasploit v4.11.4-2015071403                   ]

+ -- --=[ 1467 exploits - 840 auxiliary - 232 post        ]

+ -- --=[ 432 payloads - 37 encoders - 8 nops             ]

+ -- --=[ Free Metasploit Pro trial: http://r-7.co/trymsp ]

 

 

/usr/share/metasploit-framework/vendor/bundle/ruby/2.1.0/gems/activesupport-4.0. 13/lib/active_support/core_ext/kernel/agnostics.rb:7:in ``': Cannot allocate memory - infocmp (Errno::ENOMEM)

  from /usr/share/metasploit-framework/vendor/bundle/ruby/2.1.0/gems/activesupport-4.0 .13/lib/active_support/core_ext/kernel/agnostics.rb:7:in ``'

  from /usr/share/metasploit-framework/vendor/bundle/ruby/2.1.0/gems/rb-readline-r7-0. 5.2.0/lib/rbreadline.rb:1815:in `get_term_capabilities'

  from /usr/share/metasploit-framework/vendor/bundle/ruby/2.1.0/gems/rb-readline-r7-0. 5.2.0/lib/rbreadline.rb:2027:in `_rl_init_terminal_io'

  from /usr/share/metasploit-framework/vendor/bundle/ruby/2.1.0/gems/rb-readline-r7-0. 5.2.0/lib/rbreadline.rb:2519:in `readline_initialize_everything'

  from /usr/share/metasploit-framework/vendor/bundle/ruby/2.1.0/gems/rb-readline-r7-0. 5.2.0/lib/rbreadline.rb:3804:in `rl_initialize'

  from /usr/share/metasploit-framework/vendor/bundle/ruby/2.1.0/gems/rb-readline-r7-0. 5.2.0/lib/rbreadline.rb:4823:in `readline'

  from /usr/share/metasploit-framework/lib/rex/ui/text/input/readline.rb:132:in `readline_with_output'

  from /usr/share/metasploit-framework/lib/rex/ui/text/input/readline.rb:86:in `pgets'

  from /usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:187:in `run'

  from /usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48: in `start'

  from /usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start'

  from /usr/bin/msfconsole:48:in `<main>'

root@kali:~#

 

So thts it.i would like to know how to fix this

And Kali ver 2.0 Sana x64 bit and gnome VR 3.14.1. . I have it on my USB drive

Thanks in advance

Outcomes